Weiterleitungsseite nach Registrierung

08.09.2017 10:48 #1
Yannick Herzog
Gast

Weiterleitungsseite nach Registrierung

Hallo Herr Schmidt,

ich habe eine Weiterleitungsseite nach der Registrierung eingerichtet werde jedoch dorthin nicht weitergeleitet, sondern bleibe auf der Seite und erhalte die Fehlermeldung:


Fatal error: Uncaught exception Error with message Function name must be a string thrown in system/modules/event_manager/modules/frontend/ModuleRegistrationExt.php on line 290

#0 system/modules/core/modules/ModuleRegistration.php(318): EventManager\ModuleRegistrationExt->createNewUser(Array)
#1 system/modules/event_manager/modules/frontend/ModuleRegistrationExt.php(96): Contao\ModuleRegistration->compile()
#2 system/modules/core/modules/Module.php(287): EventManager\ModuleRegistrationExt->compile()
#3 system/modules/core/modules/ModuleRegistration.php(58): Contao\Module->generate()
#4 system/modules/event_manager/modules/frontend/ModuleRegistrationExt.php(74): Contao\ModuleRegistration->generate()
#5 system/modules/core/elements/ContentModule.php(59): EventManager\ModuleRegistrationExt->generate()
#6 system/modules/core/library/Contao/Controller.php(484): Contao\ContentModule->generate()
#7 system/modules/core/modules/ModuleArticle.php(213): Contao\Controller::getContentElement(Object(Contao\ContentModel), 'main')
#8 system/modules/tags/modules/ModuleArticle.php(26): Contao\ModuleArticle->compile()
#9 system/modules/core/modules/Module.php(287): Aurealis\ModuleArticle->compile()
#10 system/modules/core/modules/ModuleArticle.php(67): Contao\Module->generate()
#11 system/modules/core/library/Contao/Controller.php(417): Contao\ModuleArticle->generate(false)
#12 system/modules/core/library/Contao/Controller.php(277): Contao\Controller::getArticle(Object(Contao\ArticleModel), false, false, 'main')
#13 system/modules/core/pages/PageRegular.php(133): Contao\Controller::getFrontendModule('0', 'main')
#14 system/modules/core/controllers/FrontendIndex.php(285): Contao\PageRegular->generate(Object(Contao\PageModel), true)
#15 index.php(20): Contao\FrontendIndex->run()
#16 {main}

Haben Sie hierfür eine Lösung?

Viele Grüße,
Yannick Herzog
17.09.2017 15:06 #2
Christian Schmidt
Fast & Media Team
Aus Blankenburg (Harz)
315 Beiträge

Hallo Herr Herzog, 

Danke für die genaue Fehlermeldung. Sie verwenden PHP7 oder? 

Das Problem sollte mit dem nächsten Build behoben sein (erscheint nächste Woche).

26.09.2017 11:08 #3
Yannick Herzog
Gast

Hallo Herr Schmidt,

vielen Dank für die schnelle Veröffentlichung eines Fixes. Ich habe es soeben erfolgreich getestet.

Viele Grüße,
Yannick Herzog

Antworten

Datenschutz*
Was ist die Summe aus 8 und 8?